写真徒然草...

つれ\〃/なるまゝに、日ぐらしファインダーに向ひて、心に移り行くよしなしごとを、 そこはかとなく撮りつくれば、怪しうこそ物狂ほしけれ

スポンサーサイト

上記の広告は1ヶ月以上更新のないブログに表示されています。
新しい記事を書く事で広告が消せます。
  1. --/--/--(--) --:--:--|
  2. スポンサー広告|
  3. トラックバック(-)|
  4. コメント(-)

三連休の活動 3日目、月曜日

三連休3日目の月曜日は朝からずっと雨、雨、雨...。

やっとバッテリが届いたのに、飛ばせない...。

仕方なく溜まったその他の事を実行。

ナベさんのビデオスイッチはどうやらマイコンが死んでいる様で、あきらめ。代わりのマイコンを手配すると部品代は¥350だけど、送料だけで¥1,000取られる。

で、次は最近放置のQuad。
実はSQuadからフレーム載せ替えてESCとモーター変えて、ってやって試験飛行でひっくり返って、再試験でもひっくり返って、連続でペラを6本折って放置していました。
ESCがTurnigy TY-P1 25Amp HEXFETAって安物。
image3229.jpg



モーターも2728 Brushless 1000kvの安物。モーターのシャフトも2本簡単に折れて、材質に問題有り?って気持ちが萎えてました。

何故ひっくり返ったのだろう?って考えたとき、このESCはプロポから設定変更ができないからだろう、って馬鹿らしいけど専用のプログラミングカードも購入。ところが、こいつが不良品で動かない...ますます気持ちが萎えて放置数ヶ月。

しかし、バッテリと共にATMEGA書き換え用のソケットが手に入ったので、ESCの書き換えに挑戦!

-*-*-*-*- ここから下はお約束の自己責任の世界!真似してESCが燃えても知らないよ! -*-*-*-*-
って、まぁラジコンは全て自己責任の世界かも?

まずは例の一覧表でESCを探す。102行にありました!
で、表裏の写真で真偽確認。問題なし。
image3230.jpg



書き換えるプログラムがTurnigy Plushとは異なるので、改めてeXtreme Burner - AVRってのをダウンロード

使ったのはホビキンのAVRプログラマソケット
image3231.jpg



で、eXtreme Burnerを起動するとこんな画面。
eXstartup.jpg


最初は書いてあるプログラムを読み出すのに、Read Allを使う。
ソケットを押しつけて、Read Allをクリックするのですが、ソケットの押しつけが難しい!ずれると、怒られる。
eXfail.jpg


プログラムのChipの設定と違うとこんなワーニングが表示されるので、メニューのChipからATmega8を選択して再度読み出し。(ちなみにArduino Pro miniのATmega328は選択肢に無し。まぁ違うプログラムで読み書きできるからいいか?)
eXincorrectchip.jpg



上手く読み出せると、こんな感じに表示される。
eXreadsuccess.jpg


で、読み出した内容は念のため、保存しておく。戻せるかは不明。
次にESCに書き込むファイルを選択して読み込む。今回はbs.hexを使用。間違えるとESCが燃える!
で、Write Allをクリックして書き込み。失敗しても、ESCをバッテリに接続しないと燃えないので、何回か失敗しつつ、書き換え。
成功すると、こんな感じの画面になる。
eXwritesuccess.jpg



そして、モーター・受信機(ch3へ)を接続して恐る恐るバッテリ接続。
火は噴かなかったけど、立ち上がり音が以前と違う。回らない。
レンジ設定を忘れていたので、スロットル最大にして再度バッテリ接続。認識音がしたので、スロットル最低にしてレンジ設定完了。回った!

4個ESCを書き換え、それぞれのモーターとプロペラで動作確認。

MultiWiiを接続して、動作確認。
あれ?後二つのモーターが回らん?!傾けると更に傾く方向にモーターが加速する???

散々悩んでMultiWiiのレンジ設定を試している時にバッテリを接続したまま、レンジ設定の書き込みをして、書き込み完了と同時にMultiWii再起動!前のモーター二つが最大スロットルで起動!機体が身体の横で暴れてペラ2本破損、モーターシャフト2本曲がり...。
注意書きにペラ外せって書いてあるのに手抜きして危うく大怪我するところだった...。まぁペラとモーターシャフトで済んで良かったか?!

以降、ペラを外して散々やって、半日後にMegaの基板へのESCの接続位置がずれているのに気が付いた...。
指定では2、3、5、6に接続なので、最初を1つ開けて2つ接続し、1つ開けて残り2つを接続していた。しかし基板に1つめの出力は無く、結局3、4(出力なし)、6、7(Quadでは未使用)に接続していた...。
まともに接続したら、やっとアームした!

さぁ、プロペラ付けて、回そう!
回った! げげっ!!!ESCから煙が出てる!!!

慌てて停止してバッテリを抜いて、確認したら、モーターの負荷が少し重い?でも、煙が出たのは最初に書き換えたESCだから書き換えミス?
モーター直して、再度やったけど、またまた煙が出た!
ESC再度書き込みしたけど、書き込み・コンペアは成功。

再度やったけど、赤熱した素子が見えて煙が出た!

モーターとESC死亡...。

まぁ、この後、着弾した折りペラの使い先の組み立て(Reverb)もあるし、未だ手付かずのKa-8 Heritageもあるし...Quad放置決定!
(燃えたESCからマイコン外してナベさんのビデオスイッチを修復しようかな?たまたま同じ型名だし...)

長いようなイヤに短い様な三連休でした...。
  1. 2013/01/14(月) 23:12:47|
  2. ラジコン|
  3. トラックバック:0|
  4. コメント:4
<<Reverb組み立て その1 | ホーム | ホビキンからのバッテリ配達>>

コメント

mita様、いつもお世話になっております。以前に色々とアドバイス頂いた者です。
その節はありがとうございました。アドバイス頂いた案件は、基板が完成し、もう少しで飛行できそうです。
また不明なときは、お手数ですが教えて下さい。

書かれているTY-P1とmultiwiiの組み合わせ、当方も使っていますが、このESC色々と課題があるようですね。
海外含めTY-P1が燃える報告多数あるようで、困ったものです。

当方もmultiwiiのconfigをESCレンジ設定用に書替えて使った際、TY-P1を2個燃やしました。
(当方の場合はESCファームはデフォルトの状態でしたが)

よく分析していませんが、ESCに信号入れる際、無信号になるタイミングかなにかで、ESCのA/B/Cのどれかの出力が出っ放しになるようですね。
燃えた2個のESCは、一つはAポートの正出力、もう一つはCポートの負出力(間違っていたらすみません)が燃えているので、先にA/Cの負けた方が燃えたのか、都度氏出っ放しになるポートが変動するのかは不明です。(とりあえず燃えたFETのみ2個イチに交換して使っていますが、これ以上燃えても困るので試していません。)

その後ESCのファームをSimonkファームに書替え、症状出ていなかったので、デフォルトでESCに書き込んであるファームのバグと思っていましたが、Mita様の結果からすると書き換えても症状変わらないのですね。
(自分はあまり飛ばしていないのと、ESCレンジ設定プログラム用configは使わないようにしていたので症状が出なかっただけかもしれません)

因みにESCのシュリンクチューブ剥がした時、電解コンのはんだ外れていたりPWB上にはんだ玉のこっていたりと、品質的にもあまりよろしくないESCでした。。。。
  1. 2013/01/15(火) 08:43:29 |
  2. URL |
  3. mu_chin #-
  4. [ 編集]

買わないとか言ってたのに持ってるしw

毎度どーもです。
アダプタはジグ(クリップと台座とアーム)作って固定してますがそれだと両手使えて楽ですよ。
TY-P1はウチも一昨年かな?マルチ始めた頃に6枚に積んで使ってました。
プログラマ要るなら使ってないので送ったのに・・・。

アンプはどうにもダメ子なので下ろしてしまいました。
飛行機用になら使えるかな?とまだあと何個か転がってますがいります?いらないでしょw
因みに、mu_chinさんも書かれてる様に10個買ったウチの何個かはcold solderやら玉が飛び散ってたりやらで最悪でした。
まだRED BRICKシリーズのほうがマシですね。

あとTY-P1はFY90やkkmultiなんかでもアームがなかなかしないです。
何回かスロットル煽ってるうちに回ったり勝手に1発止まったりして危なくて使えませんでした。
・・・って結構前にブログで記事にしてたんですよ

http://align.sblo.jp/article/59310850.html

こんなヤツ。。
  1. 2013/01/15(火) 11:59:24 |
  2. URL |
  3. あさひな #mQop/nM.
  4. [ 編集]

mu_chinさん、ご訪問、コメントありがとうございます。
>また不明なときは、お手数ですが教えて下さい。
いつでもどうぞ!ビデオもみせてくださいね!お待ちしています。
>書かれているTY-P1とmultiwiiの組み合わせ、当方も使っていますが、このESC色々と課題があるようですね。
>海外含めTY-P1が燃える報告多数あるようで、困ったものです。
げげっ!知らずに地雷踏んだ!!!
>よく分析していませんが、ESCに信号入れる際、無信号になるタイミングかなにかで、ESCのA/B/Cのどれかの出力が出っ放しになるようですね。
確かにそんな感じでした。
>燃えた2個のESCは、一つはAポートの正出力、もう一つはCポートの負出力(間違っていたらすみません)が燃えているので、先にA/Cの負けた方が燃えたのか、都度氏出っ放しになるポートが変動するのかは不明です。(とりあえず燃えたFETのみ2個イチに交換して使っていますが、これ以上燃えても困るので試していません。)
私のはAの正出力が逝ってます。
>その後ESCのファームをSimonkファームに書替え、症状出ていなかったので、デフォルトでESCに書き込んであるファームのバグと思っていましたが、Mita様の結果からすると書き換えても症状変わらないのですね。
>(自分はあまり飛ばしていないのと、ESCレンジ設定プログラム用configは使わないようにしていたので症状が出なかっただけかもしれません)
どちらかと言うと、ESCレンジ設定プログラム用configとの組み合わせが問題かもしれません。一回ショックが加わるとたぶん後は負荷掛けるだけで燃えが進む様な...
>因みにESCのシュリンクチューブ剥がした時、電解コンのはんだ外れていたりPWB上にはんだ玉のこっていたりと、品質的にもあまりよろしくないESCでした。。。。
もったいないけど諦めて次行きます!
  1. 2013/01/15(火) 19:29:28 |
  2. URL |
  3. Y.Mita #-
  4. [ 編集]

あさひなさん、いつもご訪問、コメントありがとうございます!
>アダプタはジグ(クリップと台座とアーム)作って固定してますがそれだと両手使えて楽ですよ。
馴れると何とかなるのですが、最初の押し当てが難しいんですよ。
>プログラマ要るなら使ってないので送ったのに・・・。
あいたぁ~!やはり製作途中もブログアップしないと駄目ですね!
>アンプはどうにもダメ子なので下ろしてしまいました。
>飛行機用になら使えるかな?とまだあと何個か転がってますがいります?いらないでしょw
お気遣い、ありがとうございます。私もこのESCは諦めました。
>因みに、mu_chinさんも書かれてる様に10個買ったウチの何個かはcold solderやら玉が飛び散ってたりやらで最悪でした。
>まだRED BRICKシリーズのほうがマシですね。
完全な地雷でしたね!知らなかったぁ~!涙!
>あとTY-P1はFY90やkkmultiなんかでもアームがなかなかしないです。
>何回かスロットル煽ってるうちに回ったり勝手に1発止まったりして危なくて使えませんでした。
>・・・って結構前にブログで記事にしてたんですよ
げげげっ!見落としていた!私は機知の地雷を更に踏んだんですね!
早速使い慣れているPlushの30Aを予備含めて5個ポチリました...。
  1. 2013/01/15(火) 19:34:42 |
  2. URL |
  3. Y.Mita #-
  4. [ 編集]

コメントの投稿

管理者にだけ表示を許可する

トラックバック

トラックバックURLはこちら
http://ymita.blog9.fc2.com/tb.php/1192-d5d38b02
上記広告は1ヶ月以上更新のないブログに表示されています。新しい記事を書くことで広告を消せます。